SSO Login Issues — June 27, 2026

Incident Report for Loopio

Resolved

This incident has been resolved.
Posted Jul 04, 2026 - 16:53 UTC

Monitoring

Some Loopio users may be experiencing difficulty logging in to Loopio via Single Sign-On (SSO). If you are able to log in successfully, no action is required on your part.

If you are unable to log in via SSO, this may be related to a certificate update required on your organization's end. Please contact Loopio Support and we'll help get you back up and running.
Posted Jun 27, 2026 - 17:45 UTC
This incident affected: Primary Application (North America) and Primary Application (EU).