[Resolved] Contact Support option in Loopio Help Menu not Responsive

Incident Report for Loopio

Resolved

This incident has been resolved, and Support tickets can again be logged by selecting Contact Support in the Loopio Help menu.

We sincerely apologize for the disruption and appreciate your patience as we worked to restore this service.

If you continue to experience any issues after refreshing your screen and clearing your browser cache, please reach out to our Support Team at support@loopio.com.
Posted Apr 07, 2026 - 13:39 UTC

Identified

We are currently working on a fix for an issue where the Contact Support option in the Loopio Help menu is not responsive. We will share any updates via this page.

An alternate workflow is to submit your request through the Help Center: https://support.loopio.com/hc/en-us/requests/new or send an email to support@loopio.com
Posted Apr 01, 2026 - 19:41 UTC
This incident affected: Primary Application (North America) and Primary Application (EU).